Links not working, trouble deleting links

@Admin - I’ve had this problem come up a couple of times: I add a link to a post. I post it and try the link to make sure it works. The link doesn’t work so I try a few times to copy and paste the link but it doesn’t direct to the right page. Then I try to delete the link completely from my post but I keep getting the message that I need to add a URL. I tried multiple times to delete the link but kept getting the same message. I gave up and just edited the post adding a message to ignore the bad link.

@lovestostitch A related issue, but I’ve had issues adding links to posts as well and I’ve seen others also have the same problem. A copied and pasted URL should automatically hyperlink when added to a post, but that isn’t happening some of the time. It works when using the linking tool, but that shouldn’t be necessary. I have not had a problem with the URL’s not working when copied from my posts, but one shouldn’t need to copy and paste the link to get to another site.

Would you be able to post examples of working ones vs. not working ones? It might be a setting I have wrong but the ones I’ve tried seem to work so it’s hard for me to reproduce.

Sorry for all the questions, what do you mean by “Doesn’t work” ? Do you mean it’s not a link and can’t be clicked, or like it doesn’t go where you think it should go?

Not trying to be obtuse just trying to understand what’s going on.

When I go to the top one, it takes me to the exact URL that’s posted, which returns an NGINX page, that seems to be a misconfiguration on knittingparadise from what I can tell.

The second two in your second post seem to go to where they point and are successful.

Yes, by “doesn’t work,” I meant the link didn’t take me to the page I was trying for. I realize that this could have been Knitter’s Paradise’s problem. The problem with Our Unraveled is that it would not allow me to delete the link from my post and then repost. This has happened to me before.

Test Post:

Ok, I figured out why some work and some don’t and I think I figured out how to remove links.

The link I pasted into the text field seemed to work, and the one I added from the little “chain link” icon worked.

The one I added from the link button in the top left did the same thing yours did.

When I added the link this way, it showed up underneath the text box where I could edit or remove it afterward, this is how yours shows (the broken one).

Screenshot from 2019-08-08 06-57-16.png

Screenshot from 2019-08-08 07-02-01.png

Screenshot from 2019-08-08 06-59-54.png

Screenshot from 2019-08-08 06-58-26.png

I did use the chain in the upper left. I’ll have to try it the other way.

I just tried adding the link directly into the text box and it was successful but it would not let me delete the bad link.

@lovestostitch are you using phone or desk/lap top browser?

I’m using an IPad.

okay - the only thing I can say is that different browser do some things that cause link problems if you just cut & paste
take a close look as a facebook link sometime - enough tracking crap to make one’s head spin.

hopefully @Admin will be able to see where it is going wrong

But for that link specifically, it is the “static” that precedes that is causing the problem.
I am guessing it was cut and paste from some sort of favorites list,
and short of testing and editing prior to posting, now sure what you can do.

sorry not be more helpful

I am not a techie at all but if I can copy and paste the URL into the text box successfully but pasting it into the “add link” box doesn’t work, it seems that the problem is with the add link box. Besides that, the add link feature is problematic because it won’t allow you to delete your link. I’m glad I’m just a happy user. I totally appreciate all the work Admin is doing to get everything working.

I get this message a lot when I am browsing links within OUR. I am of course logged in…


@wheat I agree that the “static” might be what is causing trouble. Another thought, for security reasons I wonder if the site administrators have disabled links included in posts that are direct downloads. I don’t know if there is a setting for that on the platform or not. If so, that could also be causing the behavior. I noticed that particular link is directly to a PDF which would trigger a file to auto-open either in browser or in a PDF reader. Even PDF’s, which are thought of as more secure by many people, can contain malware. I generally won’t click a link to a direct download like that - one that is included in a post. (I will hover over the link to see what the extension is or where it leads before clicking.) I’d rather be directed to the site where the file resides and make my own decision about whether to open it.

I have a theory about the logged in message based on something else I am trying to understand - this may take awhile but I am suspecting it has to do with blogs & some groups require you to have joined vs the forums which are mostly open. Too much of new versions of software to wrap my head around at o be time.

Now as to how people post links - that could be a class A nightmare to try “legislate”
so yes, each of us has to take some responsibility for safe netting, imnho

Definitely agree.

I just discovered something about deleting links that may help others. In a long post, I was going to add links under some regular text, then changed my mind and simply put the link straight into the post. When I tried to submit the post, it said the URL was invalid. Well, of course, because it was now blank.

So I tried clicking the “x” at the right end of the link info box below the post typing area (below the line of emojis and whatever other special content boxes each of us might have open). The URL box went away, of course, and when I clicked “post reply,” it posted successfully.